re = /\?ab=(\d+)/m
str = '<li><a href="xyzw.do?ab=1111111111110&method=abcde&maintab=D&_UID_=111Y-T00O-U0‌​0U-PCDE-ZA7C-QQ99-0I00-0550" target="_top"> Letter</a>
<li><a href="xyzw.do?ab=2763276324872&method=abcde&maintab=D&_UID_=111Y-ABCD-EF‌​GH-IHJK-ZA7C-QQ99-0I00-0550" target="_top"> Letter</a> '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end