import Foundation
let pattern = #"\?ab=(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<li><a href="xyzw.do?ab=1111111111110&method=abcde&maintab=D&_UID_=111Y-T00O-U0‌​0U-PCDE-ZA7C-QQ99-0I00-0550" target="_top"> Letter</a>
<li><a href="xyzw.do?ab=2763276324872&method=abcde&maintab=D&_UID_=111Y-ABCD-EF‌​GH-IHJK-ZA7C-QQ99-0I00-0550" target="_top"> Letter</a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)