use strict;
my $str = '<li><a href="xyzw.do?ab=1111111111110&method=abcde&maintab=D&_UID_=111Y-T00O-U0‌​0U-PCDE-ZA7C-QQ99-0I00-0550" target="_top"> Letter</a>
<li><a href="xyzw.do?ab=2763276324872&method=abcde&maintab=D&_UID_=111Y-ABCD-EF‌​GH-IHJK-ZA7C-QQ99-0I00-0550" target="_top"> Letter</a> ';
my $regex = qr/\?ab=(\d+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}