package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<input type='hidden' name='auth_key' value='(.*?)' \/>`)
var str = `<input type='hidden' name='auth_key' value='880ea6a14ea49e853634fbdc5015a024' />`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}