import Foundation
let pattern = #"<input type='hidden' name='auth_key' value='(.*?)' \/>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<input type='hidden' name='auth_key' value='880ea6a14ea49e853634fbdc5015a024' />"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}