$re = '/<input type=\'hidden\' name=\'auth_key\' value=\'(.*?)\' \/>/';
$str = '<input type=\'hidden\' name=\'auth_key\' value=\'880ea6a14ea49e853634fbdc5015a024\' />';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);