// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<input type='hidden' name='auth_key' value='(.*?)' \/>").unwrap();
let string = "<input type='hidden' name='auth_key' value='880ea6a14ea49e853634fbdc5015a024' />";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}