#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!200\b)-?\d+\b"
Local $sString = "0" & @CRLF & _
"3" & @CRLF & _
"199" & @CRLF & _
"20000" & @CRLF & _
"200001" & @CRLF & _
"221B" & @CRLF & _
"200 this is excluded" & @CRLF & _
"201 " & @CRLF & _
"-1 this should be a match" & @CRLF & _
"-10 this should be a match" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")