import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!200\\b)-?\\d+\\b";
final String string = "0\n"
+ "3\n"
+ "199\n"
+ "20000\n"
+ "200001\n"
+ "221B\n"
+ "200 this is excluded\n"
+ "201 \n"
+ "-1 this should be a match\n"
+ "-10 this should be a match\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}