re = /^(?!200\b)-?\d+\b/m
str = '0
3
199
20000
200001
221B
200 this is excluded
201
-1 this should be a match
-10 this should be a match
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end