using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!200\b)-?\d+\b";
string input = @"0
3
199
20000
200001
221B
200 this is excluded
201
-1 this should be a match
-10 this should be a match
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}