const regex = new RegExp('^(?!200\\b)-?\\d+\\b', 'gm')
const str = `0
3
199
20000
200001
221B
200 this is excluded
201
-1 this should be a match
-10 this should be a match
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}