const regex = /[\w-]+="[^"]*"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\w-]+="[^"]*"', 'g')
const str = `<r p="68154" c="36716" t="1" d="1"/><r p="68139" c="36697" t="1" d="1"/><r p="68082" c="36655" t="1" d="1"/><r p="280" c="401" t="1" d="1"/><r p="262" c="363" t="1" d="1"/><r p="262" c="30" t="2" d="0"/><r p="113" c="202" t="1" d="1"/><r p="113" c="12" t="3" d="0"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}