$re = '/[\w-]+="[^"]*"/';
$str = '<r p="68154" c="36716" t="1" d="1"/><r p="68139" c="36697" t="1" d="1"/><r p="68082" c="36655" t="1" d="1"/><r p="280" c="401" t="1" d="1"/><r p="262" c="363" t="1" d="1"/><r p="262" c="30" t="2" d="0"/><r p="113" c="202" t="1" d="1"/><r p="113" c="12" t="3" d="0"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);