import re
regex = re.compile(r"[\w-]+=\"[^\"]*\"")
test_str = "<r p=\"68154\" c=\"36716\" t=\"1\" d=\"1\"/><r p=\"68139\" c=\"36697\" t=\"1\" d=\"1\"/><r p=\"68082\" c=\"36655\" t=\"1\" d=\"1\"/><r p=\"280\" c=\"401\" t=\"1\" d=\"1\"/><r p=\"262\" c=\"363\" t=\"1\" d=\"1\"/><r p=\"262\" c=\"30\" t=\"2\" d=\"0\"/><r p=\"113\" c=\"202\" t=\"1\" d=\"1\"/><r p=\"113\" c=\"12\" t=\"3\" d=\"0\""
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")