import Foundation
let pattern = #"[\w-]+="[^"]*""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<r p="68154" c="36716" t="1" d="1"/><r p="68139" c="36697" t="1" d="1"/><r p="68082" c="36655" t="1" d="1"/><r p="280" c="401" t="1" d="1"/><r p="262" c="363" t="1" d="1"/><r p="262" c="30" t="2" d="0"/><r p="113" c="202" t="1" d="1"/><r p="113" c="12" t="3" d="0""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)