const regex = /[['](.*?\(Delete\).*?)[\]']/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[[\'](.*?\\(Delete\\).*?)[\\]\']', 'g')
const str = `blah blah [manikv (Delete) 4916258] blah blah
blah blah 'morl20 (Delete) 180977' blah blah`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}