$re = '/[[\'](.*?\(Delete\).*?)[\]\']/';
$str = 'blah blah [manikv (Delete) 4916258] blah blah
blah blah \'morl20 (Delete) 180977\' blah blah';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);