import re
regex = re.compile(r"[['](.*?\(Delete\).*?)[\]']")
test_str = ("blah blah [manikv (Delete) 4916258] blah blah\n"
"blah blah 'morl20 (Delete) 180977' blah blah")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")