package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\.][a-zA-Z0-9_\.+-]+[^\.]@[^-][a-zA-Z0-9-]+\.[a-zA-Z0-9-\.]+$
`)
var str = `.email@example.com
email.@example.com
email@example.com (Joe Smith)
email@-example.com
email@111.222.333.44444`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}