// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^\.][a-zA-Z0-9_\.+-]+[^\.]@[^-][a-zA-Z0-9-]+\.[a-zA-Z0-9-\.]+$
").unwrap();
let string = ".email@example.com
email.@example.com
email@example.com (Joe Smith)
email@-example.com
email@111.222.333.44444";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}