# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:[\s\\_]|(?<!\d)\/(?!\d))+/\n/gu;t' <<< "925/123 Black/Jack"