use strict;
my $str = '925/123 Black/Jack';
my $regex = qr@(?:[\s\\_]|(?<!\d)/(?!\d))+@up;
my $subst = '\\n';
my $result = $str =~ s@$regex@$subst@rg;
print "The result of the substitution is' $result\n";