#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)(?<=Project Contact\(s\)\:\n)(.*?)(?=\nLink)"
Local $sString = "Product Type: abc xyz ABC XYZ 1254" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Project Contact(s):" & @CRLF & _
"abc@gmail.com" & @CRLF & _
"xyz@outlook.com" & @CRLF & _
"Demo@gmail.com" & @CRLF & _
"" & @CRLF & _
"Link"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")