re = /(?s)(?<=Project Contact\(s\)\:\n)(.*?)(?=\nLink)/m
str = 'Product Type: abc xyz ABC XYZ 1254
Project Contact(s):
abc@gmail.com
xyz@outlook.com
Demo@gmail.com
Link'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end