$re = '/(?s)(?<=Project Contact\(s\)\:\n)(.*?)(?=\nLink)/m';
$str = 'Product Type: abc xyz ABC XYZ 1254
Project Contact(s):
abc@gmail.com
xyz@outlook.com
Demo@gmail.com
Link';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);