using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)(?<=Project Contact\(s\)\:\n)(.*?)(?=\nLink)";
string input = @"Product Type: abc xyz ABC XYZ 1254
Project Contact(s):
abc@gmail.com
xyz@outlook.com
Demo@gmail.com
Link";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}