const regex = /(?s)(?<=Project Contact\(s\)\:\n)(.*?)(?=\nLink)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)(?<=Project Contact\\(s\\)\\:\\n)(.*?)(?=\\nLink)', 'gm')
const str = `Product Type: abc xyz ABC XYZ 1254
Project Contact(s):
abc@gmail.com
xyz@outlook.com
Demo@gmail.com
Link`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}