using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<img[^>]+src\s*=\s*([""'])(((?!alkatreszkepek).)*?))\1[^>]*>";
string input = @"<IMG border=0 alt=""alkatreszkepek"" src=""http:///Images/white.gif"" width=5 height=1><IMG border=0 alt="" src=""http:///Images/white.gif"" width=170 height=1><img src=""/asdsa/alkatreszkepek/aasdsa.jpg""><IMG border=0 alt="" src=""http:///Images/white.gif"" width=170 height=1><IMG border=0 alt="" src=""http:///Images/white.gif"" width=2 height=1>
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}