use strict;
my $str = '<IMG border=0 alt="alkatreszkepek" src="http:///Images/white.gif" width=5 height=1><IMG border=0 alt="" src="http:///Images/white.gif" width=170 height=1><img src="/asdsa/alkatreszkepek/aasdsa.jpg"><IMG border=0 alt="" src="http:///Images/white.gif" width=170 height=1><IMG border=0 alt="" src="http:///Images/white.gif" width=2 height=1>
';
my $regex = qr/(?:<img[^>]+src\s*=\s*(["'])(((?!alkatreszkepek).)*?))\1[^>]*>/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}