import Foundation
let pattern = #"(?:<img[^>]+src\s*=\s*(["'])(((?!alkatreszkepek).)*?))\1[^>]*>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
<IMG border=0 alt="alkatreszkepek" src="http:///Images/white.gif" width=5 height=1><IMG border=0 alt="" src="http:///Images/white.gif" width=170 height=1><img src="/asdsa/alkatreszkepek/aasdsa.jpg"><IMG border=0 alt="" src="http:///Images/white.gif" width=170 height=1><IMG border=0 alt="" src="http:///Images/white.gif" width=2 height=1>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)