re = /(?:<img[^>]+src\s*=\s*(["'])(((?!alkatreszkepek).)*?))\1[^>]*>/i
str = '<IMG border=0 alt="alkatreszkepek" src="http:///Images/white.gif" width=5 height=1><IMG border=0 alt="" src="http:///Images/white.gif" width=170 height=1><img src="/asdsa/alkatreszkepek/aasdsa.jpg"><IMG border=0 alt="" src="http:///Images/white.gif" width=170 height=1><IMG border=0 alt="" src="http:///Images/white.gif" width=2 height=1>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end