# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:<img[^>]+src\s*=\s*([\"'])(((?!alkatreszkepek).)*?))\1[^>]*>"
test_str = ("<IMG border=0 alt=\"alkatreszkepek\" src=\"http:///Images/white.gif\" width=5 height=1><IMG border=0 alt=\"\" src=\"http:///Images/white.gif\" width=170 height=1><img src=\"/asdsa/alkatreszkepek/aasdsa.jpg\"><IMG border=0 alt=\"\" src=\"http:///Images/white.gif\" width=170 height=1><IMG border=0 alt=\"\" src=\"http:///Images/white.gif\" width=2 height=1>\n")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.