# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/if\s+\((.+)\)\s+{\s+(.+)\s+}\s+else\s+{\s+(.+)\s+}/IF($1, $2, $3)/g;t' <<< "if (a > 5) {
a = 5;
}
else {
a = 10;
}"