// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"if\s+\((.+)\)\s+{\s+(.+)\s+}\s+else\s+{\s+(.+)\s+}").unwrap();
let string = "if (a > 5) {
a = 5;
}
else {
a = 10;
}";
let substitution = "IF($1, $2, $3)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}