const regex = /if\s+\((.+)\)\s+{\s+(.+)\s+}\s+else\s+{\s+(.+)\s+}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('if\\s+\\((.+)\\)\\s+{\\s+(.+)\\s+}\\s+else\\s+{\\s+(.+)\\s+}', 'g')
const str = `if (a > 5) {
a = 5;
}
else {
a = 10;
}`;
const subst = `IF($1, $2, $3)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);