re = /if\s+\((.+)\)\s+{\s+(.+)\s+}\s+else\s+{\s+(.+)\s+}/
str = 'if (a > 5) {
a = 5;
}
else {
a = 10;
}'
subst = 'IF($1, $2, $3)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result