import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "if\\s+\\((.+)\\)\\s+\\{\\s+(.+)\\s+\\}\\s+else\\s+\\{\\s+(.+)\\s+\\}";
final String string = "if (a > 5) {\n"
+ " a = 5;\n"
+ "}\n"
+ "else {\n"
+ " a = 10;\n"
+ "}";
final String subst = "IF($1, $2, $3)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}