#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*?\b(uk_en)\b.*?\bneedle\b.*?$"
Local $sString = "id: page_name" & @CRLF & _
" locale: uk_en" & @CRLF & _
" " & @CRLF & _
" <div> placeholder placeholder placeholder placeholder placeholder placeholder</div>" & @CRLF & _
" <span>placeholder placeholder placeholder placeholder placeholder placeholder </span>" & @CRLF & _
" <p>Needle</p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")