$re = '/^.*?\b(uk_en)\b.*?\bneedle\b.*?$/m';
$str = 'id: page_name
locale: uk_en
<div> placeholder placeholder placeholder placeholder placeholder placeholder</div>
<span>placeholder placeholder placeholder placeholder placeholder placeholder </span>
<p>Needle</p>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);