re = /^.*?\b(uk_en)\b.*?\bneedle\b.*?$/m
str = 'id: page_name
locale: uk_en
<div> placeholder placeholder placeholder placeholder placeholder placeholder</div>
<span>placeholder placeholder placeholder placeholder placeholder placeholder </span>
<p>Needle</p>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end