import Foundation
let pattern = #"^.*?\b(uk_en)\b.*?\bneedle\b.*?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
id: page_name
locale: uk_en
<div> placeholder placeholder placeholder placeholder placeholder placeholder</div>
<span>placeholder placeholder placeholder placeholder placeholder placeholder </span>
<p>Needle</p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}