const regex = /^.*?\b(uk_en)\b.*?\bneedle\b.*?$/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?\\b(uk_en)\\b.*?\\bneedle\\b.*?$', 'm')
const str = `id: page_name
locale: uk_en
<div> placeholder placeholder placeholder placeholder placeholder placeholder</div>
<span>placeholder placeholder placeholder placeholder placeholder placeholder </span>
<p>Needle</p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}