# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\.d)\.(?<ext>[cm]?ts|tsx)$/.$1/gm;t' <<< "something.ts
something.tsx
something.cts
something.mts
something.d.ts"