use strict;
my $str = 'something.ts
something.tsx
something.cts
something.mts
something.d.ts';
my $regex = qr/(?<!\.d)\.(?<ext>[cm]?ts|tsx)$/mp;
my $subst = '.$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";