#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!\.d)\.(?<ext>[cm]?ts|tsx)$"
Local $sString = "something.ts" & @CRLF & _
"something.tsx" & @CRLF & _
"something.cts" & @CRLF & _
"something.mts" & @CRLF & _
"something.d.ts"
Local $sSubst = ".$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)