import Foundation
let pattern = #"(?<!\.d)\.(?<ext>[cm]?ts|tsx)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
something.ts
something.tsx
something.cts
something.mts
something.d.ts
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #".$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)