$re = '/(?<!\.d)\.(?<ext>[cm]?ts|tsx)$/m';
$str = 'something.ts
something.tsx
something.cts
something.mts
something.d.ts';
$subst = ".$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;