using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\*{2}Start\*{2}(.*?)\*{2}End\*{2}";
string input = @"za e e**Start**Good1**End**ds dq**Start**Good2**End**sds df";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}