re = /\*{2}Start\*{2}(.*?)\*{2}End\*{2}/
str = 'za e e**Start**Good1**End**ds dq**Start**Good2**End**sds df'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end